Codeeditor_XH

Blatt mit Tags

Codeeditor_XH bietet einen Ersatz für die einfachen Textareas in CMSimple_XHs Administrationsmodus, um das Template, das Stylesheet und die Stylesheets der Plugins zu bearbeiten. Des weiteren kann es als Inhalts-Editor der Website verwendet werden.

Codeeditor_XH ist kein WYSIWYG oder WYSIWYM Editor, sondern es erlaubt den Quellcode direkt zu bearbeiten, und bietet Syntaxhighlighting, Zeilennummerierung, Code-Einrückung und -Faltung, Anzeige zusammengehöriger Klammernpaare, optionales Zeilenumbrechen, Filebrowser-Integration und Suchen und Ersetzen.

Das Plugin benötigt CMSimple_XH ≥ 1.6 und PHP ≥ 5.2.0. Es kann unter Einhaltung der GPLv3 verwendet werden.

Änderungen sind im Changelog aufgeführt. Ausführliche Informationen erhalten Sie online im Handbuch.

Wenn Sie bereits wenigstens Version 1.0 installiert haben, können Sie den Patch herunter laden und installieren. Dieser überschreibt weder Konfigurations-, Sprach- noch CSS-Dateien.